Black screen after "Loading Portal" on some Portals

Wednesday, 22 November 2017 | Views: 25482

Smart STB gets black (white/grey) screen after "Loading Portal"?

Sometimes you may get white screen, grey screen, etc.

(Depending on the TV and OS)



Possible reasons:
  • Sometimes Portal redirect will cause this due to limitations of some Smart TV platforms. We recommend putting in the direct URL to the Portal.

    Correct Portal URL are like
    http://some-provider.tld/stalker_portal/c/index.html
    http://box.some-provider.tld/c/index.html

    Wrong Portal URL looks like
    http://box.some-provider.tld/
    http://stb.some-provider.tld/
    http://mag.box.some-provider.tld/

    that redirects to
    http://some-provider.tld/stalker_portal/c/index.html

  • If you are using other emulator like STBEmu to access the same Portal with the same Virtual MAC address then it's most likely that Provider has detected a conflict (a cloned device) and will block access or lock it only to the first device that logged in.
    Solution: ask your Provider to DELETE your account from the Portal. Not Disable, but completely DELETE it. Along with the Virtual MAC address. After that ask them to RECREATE your account. And make sure you login ONLY with Smart STB. If you want to use the Portals with other apps at the same time make sure you have a separate account for this. Going into the Portal from many devices with same Virtual MAC will cause problems!
  • Another common reason is wrong time and date setting on TV or wrong Clock source setting inside the app.
    Please go to app's setting by pressing OK/Center key as soon as you see Loading Portal, then go to System Settings > Advanced settings and change Clock Source to Auto (Default) like shown below.

    Make sure your TV's time/clock and timezone settings are correct and you get the correct time and date on your TV.
  • Other reason for this could be that Portal maybe having technical difficulties. Example: server is overloaded, database is broken, etc.
  • Finally make sure your Portal URL is correct. Sometimes incorrect Portal URL can result in black screen on TV because app is expecting a Portal but got an unexpected server response due to the wrong URL. Check above to see how correct Portal URL looks like.

Back to list